08 September 2011

NetBeans 7 and Maven 3 dependecy problem? Not so fast..

The other day me and a colleague faced some weird behavior on Maven's part when downloading dependencies.

What made it worse is that he was using a NetBeans 7.0.1 and I am still on the 6.9.1 so we tried to dig around what was causing this unexpected behavior.

It just happens that NetBeans 7.x has a different embedded version of Maven, the version 3 to be more precise, and what was seen as 'okay' for Maven to deal in the version 2 stopped being the case with the new version. Apparently for the better.

We then changed the IDE to point to a Maven 2 installation and voilá. Everything was working like a charm.

Check the screenshot below for more information:




No comments: